ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Murdoch" <adammurdoch...@yahoo.com>
Subject RE: cvs commit: jakarta-ant/proposal/myrmidon/src/testcases/org/apache/myrmidon/components/deployer DefaultDeployerTest.java TestConverter1.java TestType1.java
Date Sat, 02 Feb 2002 21:59:07 GMT


> -----Original Message-----
> From: Peter Donald [mailto:peter@apache.org]
> Sent: Sunday, 3 February 2002 12:17 AM
> To: Ant Developers List
> Subject: Re: cvs commit:
> jakarta-ant/proposal/myrmidon/src/testcases/org/apache/myrmidon/componen
> ts/deployer DefaultDeployerTest.java TestConverter1.java TestType1.java
> 
> 
> On Sat, 2 Feb 2002 23:51, adammurdoch@apache.org wrote:
> >   /**
> >    * A general-purpose type definition.
> >    *
> >    * @author <a href="mailto:adammurdoch@apache.org">Adam Murdoch</a>
> >    */
> >   public class GeneralTypeDefinition
> >       extends TypeDefinition
> >   {
> >       private String m_name;
> 
> vs
> 
> >   public abstract class TypeDefinition
> >   {
> 
> Is there any need to separate out the above two classes? From the 
> looks of 
> things - no - but is there something else you have in mind?
> 

Not particularly - I added GeneralTypeDefinition so that I could move setType() and setName()
out of TypeDefinition, where they were being inherited by ConverterDefinition (and so visible
as attributes in <converter-def>).  Maybe we could rename TypeDefinition -> AbstractTypeDefinition
and GeneralTypeDefinition -> TypeDefinition.

There's still a few things I'd like to do with this:

* In DefaultDeployer, load up the typelib descriptor using TypeDefinition objects and introspection.

* Add a ServiceDefinition sub-class, and deploy services from the typelib descriptor.  Maybe
add a <service-def> task as well.  Need to think a little more about what "deploy services"
means.  Any problems with putting the service definitions in ant-descriptor.xml, rather than
ant-services.xml?

* I'd like to axe the <converters> element in ant-descriptor.xml, and move the converters
to the <types> element.

* Add TypeDefinition factory method to Deployer, something like the following, and use it
to replace the various -def tasks with a single general-purpose task (similar to how TypeInstanceTask
works):

interface Deployer {  
  TypeDefinition createTypeDefinition( String role ), 
}


> >   /**
> >    * A base class for tests for the default components.
> >    *
> >    * @author <a href="mailto:adammurdoch@apache.org">Adam Murdoch</a>
> >    */
> >   public class ComponentTestBase extends TestCase
> 
> Do you want to rename this to AbstractComponentTest because that 
> fits in with 
> the naming patterns of swing (which is consistent with the rest of the 
> myrmidon codebase).
> 

Sure, I guess.  Does it matter that it isn't abstract?


Adam


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message