ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Hatcher" <jakarta-...@ehatchersolutions.com>
Subject Re: cvs commit: jakarta-ant/src/main/org/apache/tools/ant/taskdefs/optional/i18n Translate.java
Date Thu, 14 Feb 2002 22:17:55 GMT
----- Original Message -----
From: "Magesh Umasankar" <umagesh@apache.org>
To: "Ant Developers List" <ant-dev@jakarta.apache.org>
Sent: Thursday, February 14, 2002 5:02 PM
Subject: Re: cvs commit:
jakarta-ant/src/main/org/apache/tools/ant/taskdefs/optional/i18n
Translate.java


> From: "Erik Hatcher" <jakarta-ant@ehatchersolutions.com>
>
> >
> > >   +        String l_BundleFile = bundleFile + ".properties";
> >
> > What coding standards is l_BundleFile?  *ick*
> >
>
> l_ for local - I am not standardizing or
> anything - I just thought this variable name
> was better than String b ;-)

Ok.... I'm just not a fan of prefixes like that....

> If there is any coding standard which we have
> consensus upon that says I cannot use this
> variable name, then please show it :-)

I just stick with The Elements of Java Style standards, and it doesn't say
not to do that, but no examples show the "l_" style.

> > Also, this code change was a fair bit more than
> > removing "an unused local variable" so we should
> > probably note that in our commit comments like
> > "reformatted/refactored code".
>
> Not really - aside from introduction of
> a local variable and removal of unused
> variable, nothing major happened other
> than doing a "Shift-Tab" to remove
> existing icky formatting.  While I *could*
> have drawled on in the CVS log, I just
> preferred keeping it to what was the primary
> difference IMO, that is all.

Ok, sorry, just looked like a lot of differences because of the renamed
variable.

    Erik


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message