ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Magesh Umasankar" <umag...@apache.org>
Subject Re: cvs commit: jakarta-ant/src/main/org/apache/tools/ant/taskdefs/optional/i18n Translate.java
Date Fri, 25 Jan 2002 16:10:55 GMT
From: "Stephane Bailliez" <sbailliez@imediation.com>

> It is not dramatic because it's a bean setter, but the I prefer
> 
> public void setFile(File value) {
> file = value;
> }

This is nice, but when you have multiple arguments,
you would end up with value1, value2, etc, or
fileValue, isOverwriteValue, etc?  My guess is
you would choose fileValue over value1.  So,
that makes it Value a suffix of the argument
which is not very different from having 
'a' as the prefix of an argument.

> though my preferences goes to the
> invalid-becoz-not-following-sun-coding-guidelines:
> 
> public void setFile(File file) {
> _file = file;
> }

Problem is when file is already a protected
variable.  We cannot rename that to _file in Ant1
while at the same time be consistent in naming.

> 
> It makes a clear distinction. :)
> 

I agree it does, but so does the following ;-)

this.file = file;

Though I made this change, I was doing it just
because QA complained - otherwise, I wouldn't have.
As this seems to be snowballing into issues,
I will revert the commit and lets see where the
discussion heads...

> btw FYI the next version of IDEA codename Ariadna (Ariadne) will make the
> distinction between instance, formal parameter and local variable.

Cool.

> 
> Stephane
> 

Cheers,
Magesh



--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message