ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Magesh Umasankar" <umag...@apache.org>
Subject Re: cvs commit: jakarta-ant/src/main/org/apache/tools/ant/taskdefs/optional/i18n Translate.java
Date Fri, 25 Jan 2002 15:50:53 GMT
From: "Erik Hatcher" <jakarta-ant@ehatchersolutions.com>
> From: <umagesh@apache.org>
> >   -    public void setFile(File file) {
> >   -        this.file = file;
> >   +    public void setFile(File aFile) {
> >   +        this.file = aFile;
> >        }
>
> I'm not fond of this change.... this means that the Javadoc will show the
> parameter as "aFile" rather than "file".
>
> I understand the rationale to making the method attribute different from
the
> member variable, although my style is still to leave them the same.  I
think
> the prefixed underscores for private member variables is perhaps a better

Let's say a setter method sets a protected member
variable.  Changing the protected member variable
name in Ant1 would not be possible.  So, I sacrificed
outwards elegance for internal consistency - I wouldn't
like to name private members alone as m_whatever and
rename arguments to a_whatever or do nothing at all in
case they modified protected members.

> scheme.  Anyway, I think the outward interface and documentation is more
> important than the internal naming conventions.

+1, but how to achieve that in a consistent manner in Ant1
while at the same time satisfy Quality Analyzer?

>
>     Erik
>

Cheers,
Magesh



--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message