ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nico Seessle" <n...@apache.org>
Subject Re: Environment problems
Date Tue, 15 Jan 2002 19:18:19 GMT
----- Original Message -----
From: "Kevin Jones" <kevinj@develop.com>
To: "Ant-Dev" <ant-dev@jakarta.apache.org>
Sent: Tuesday, January 15, 2002 3:22 PM
Subject: Environment problems


> I'm using Ant on JDK 1.4 (rc1) and .Net Server Enterprise beta 3 (this
> is the replacement for W2kK Advanced Server) and I can't use the
> <property environment="env"/> setting. I get the following error
>
> "c:\winnt\system32\ntvdm.exe
> Error while setting up the environment for the application."
>
> Ant with JDK1.4 and Windows 2000 works OK as does Ant on .Net Enterprise
> Server with JDK 1.3.1
>
> So it's some combination of Ant1.4/JDK1.4/.Net Enterprise server.
>
> This is a 'heads-up' for you guys (i.e. I know I'm running beta software
> and don't expect an immediate fix even if one is needed), assuming you
> haven't seen this before. As this is all on beta products should I still
> create a bug in bugzilla?
>

Do you have the Source for Ant? Can you modify
org.apache.tools.ant.taskdefs.Execute.java and replace all occurences of

            if ( osname.indexOf("nt") >= 0 || osname.indexOf("2000") >= 0 )
{

with

            if ( osname.indexOf("nt") >= 0 ||
                 osname.indexOf("2000") >= 0 ||
                 osname.indexOf("xp") >= 0) {

and tell us if that works better for you?

Sorry, I have no XP available so I can't test that, but if you can test it I
(or someone else, if someelse is faster?) can do the change and commit it.

Seems to be a "bug fix" in JDK 1.4.

Nico






--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message