ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: removing deprecated stuff
Date Mon, 03 Dec 2001 15:09:27 GMT
On Mon, 3 Dec 2001, Sam Ruby <rubys@us.ibm.com> wrote:

> Stefan Bodewig wrote:
>>
>> (not Ant itself as an older
>> version of Ant won't have the -legacy switch, obviously)
> 
> Just curious, what's "obvious" about that statement?

Ant 1.4.1 won't be magically replaced with a version that contains a
backported -legacy switch.

> To date, it appears that the working assumption is that developers
> will bootstrap when necessary.

"Ant" developers are expected to bootstrap Ant if necessary, same for
people who want to build their "released" Ant version from sources.

> By the way, I am *very* concerned that -legacy will be used too
> aggressively.  IMHO, it should only be used after a *significant*
> period of deprecation, containing at a minimum one public release.

At least I have never said something different.  When I proposed it
(actually have been thinking loud, as I didn't really propose it), I
talked about affecting all stuff that has been deprecated in Ant 1.4 -
which would be two releases ago when Ant 1.5 appears.

Stefan

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message