ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Magesh Umasankar" <umag...@apache.org>
Subject Re: removing deprecated stuff
Date Fri, 07 Dec 2001 06:40:40 GMT
From: "Ken Wood" <kwood@i2.com>

> I imagine anyone who jumps from 1.1 to 1.5:

It is not like Version 1 to 2.  It is more like moving from
version 3.1 of windows to 3.11

>   a. Understands the industry and 
>      will know things have changed. Imagine someone who

Why work on backward compatibility if we assume this?

>   b. Is capable of reading the manual and learning what
>      has changed, and adapting.

Sure.

>   c. <smiley> get what they deserve if they don't grok a & b </smiley>

:-)  That is no way to build a user base.

> If we follow this logic to its absurd conclusion, every program
> should carry it's excess baggage forward from every release, just
> to accommodate the minority.

Major versions maybe where you ax excess baggage with total abandon?

> I feel that the bulk of the Ant users migrate from release
> to release in a controlled, orderly manner. By worrying about
> the tiny few who install Ant 1.0 and then years later decide
> to upgrade to Ant 1.99999, we are doing the majority a disservice.

I know files in gump which still use <copydir>

Magesh



--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message