ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: cvs commit: jakarta-ant/src/main/org/apache/tools/ant/taskdefs/compilers DefaultCompilerAdapter.java
Date Wed, 21 Nov 2001 17:47:19 GMT
On Wed, 21 Nov 2001, Magesh Umasankar <umagesh@apache.org> wrote:

> From: "Stefan Bodewig" <bodewig@apache.org>
>
>> Why doesn't classic for JDK > 1.1 use it as well?  extJavac?
> 
> Good point.  How do I test what version of compiler is being used?

check the version of the current VM - this is not perfect, but we use
the same check to decide, whether we should pass -g:none as well 8-)

> What's the deal with extJavac?

extJavac is the forked version of javac - if your forked javac happens
to be the modern one, we already have support for it thanks to your
patch, if you add the flag in the classic case as well, you should be
done.

Stefan

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message