ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 5192] New: - ant.bat missing quotes around ANT_HOME
Date Fri, 30 Nov 2001 04:41:31 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=5192>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=5192

ant.bat missing quotes around ANT_HOME

           Summary: ant.bat missing quotes around ANT_HOME
           Product: Ant
           Version: 1.1
          Platform: Other
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Other
        AssignedTo: ant-dev@jakarta.apache.org
        ReportedBy: wick@camosun.bc.ca


Line 15 of ant.bat reads:
if %ANT_HOME%a==a set ANT_HOME=%DEFAULT_ANT_HOME%

This line fails if ANT_HOME is set to a directory that includes
spaces, e.g. c:\program files\ant
If one puts quotes around that value, e.g. "c:\program files\ant"
then the batch files fails later.

It appears that adding quotes as is the following solves the problem:
if "%ANT_HOME%a"==a set ANT_HOME=%DEFAULT_ANT_HOME%

Darrell

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message