ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 5025] - Execute still fails when failonerror=false and the error is program not found
Date Tue, 27 Nov 2001 20:06:37 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=5025>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=5025

Execute still fails when failonerror=false and the error is program not found





------- Additional Comments From steve_l@iseran.com  2001-11-27 12:06 -------
I have just stuck in the patch for this, but when I was doing the 
documentation I saw that this task has failonerror=fase

So anyone using this task by default will have been ignoring the return code 
but still bailing when the exe was missing, something I have just changed for 
a complete silent failure.

Better to have another property (name TBD) which controls if the task should 
fail if exec fails, and have that set to true.

This is ugly, but I cant see how else to deploy the 'fix' without breaking 
builds. 

If exec had had failonerror=true from the outset things would be easier.

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message