ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <pe...@apache.org>
Subject Re: JDK 1.3
Date Wed, 21 Nov 2001 19:52:21 GMT
On Thu, 22 Nov 2001 06:38, MNewcomb@tacintel.com wrote:
> In the Ant manual, it states:
> "For the current version of Ant, you will also need a JDK installed on your
> system, version 1.1 or later. A future version of Ant will require JDK 1.2
> or later."
>
> Have we committed to JDK 1.2? 

ant1.x will always be 1.1 compatible.

> Since 1.4 will be available soon, can we at
> least require people to go to JDK 1.3?  I have a ShutdownHook patch ready
> to go, but it depends upon Runtime.addShutdownHook().

If you can add the hooks via reflection and not fail on 1.2 or 1.2 JVMs then 
send it in.

-- 
Cheers,

Pete

*-----------------------------------------------------------------------*
PROGRAM: n.  a magic spell cast over a computer allowing it to turn
one's input into error messages.  v.t.  to engage in a pastime similar
to banging one's head against a wall, but with fewer opportunities for 
reward.
*-----------------------------------------------------------------------*

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message