ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <dona...@apache.org>
Subject Re: ant not building properly with jikes 1.15
Date Sat, 10 Nov 2001 00:21:50 GMT

Both jikes 1.11 and jikes 1.15 works for me. I did

cvs co jakarta-ant
./bootstrap.sh
./build.sh
./build.sh install

and used the ant installed for my other apps and all worked fine. However 
there are some issues with jikes1.15 I am told. It is meant to be the most 
unstable jikes yet so it may be best to go back to 1.14 and see if something 
odd is going on there.

On Sat, 10 Nov 2001 09:48, Steve Loughran wrote:
> I just rebuilt ant (clean, scrubbed everything,), and  now it aint working,
> even on build.xml.. looks like I am encountering some parser problem, even
> on the ant build file itself
>
>
>  [property] Loading C:\Documents and Settings\slo\.ant.properties
>  [property] Unable to find property file: C:\Documents and
> Settings\slo\.ant.pro
> perties
>
> BUILD FAILED
>
> java.lang.VerifyError: (class:
> org/apache/tools/ant/ProjectHelper$DataTypeHandle
> r, method: <init> signature:
> (Lorg/apache/tools/ant/ProjectHelper;Lorg/xml/sax/D
> ocumentHandler;)V) Expecting to find object/array on stack
>         at
> org.apache.tools.ant.ProjectHelper$ProjectHandler.handleDataType(Proj
> ectHelper.java)
>         at
> org.apache.tools.ant.ProjectHelper$ProjectHandler.startElement(Projec
> tHelper.java)
>         at
> org.xml.sax.helpers.XMLReaderAdapter.startElement(XMLReaderAdapter.ja
> va:333)
>         at
> org.apache.crimson.parser.Parser2.maybeElement(Parser2.java:1490) at
> org.apache.crimson.parser.Parser2.content(Parser2.java:1779) at
> org.apache.crimson.parser.Parser2.maybeElement(Parser2.java:1507) at
> org.apache.crimson.parser.Parser2.parseInternal(Parser2.java:500) at
> org.apache.crimson.parser.Parser2.parse(Parser2.java:305) at
> org.apache.crimson.parser.XMLReaderImpl.parse(XMLReaderImpl.java:442)
>
>         at
> org.xml.sax.helpers.XMLReaderAdapter.parse(XMLReaderAdapter.java:223)
>
>         at javax.xml.parsers.SAXParser.parse(SAXParser.java:362)
>         at org.apache.tools.ant.ProjectHelper.parse(ProjectHelper.java)
>         at
> org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.jav
> a)
>         at org.apache.tools.ant.Main.runBuild(Main.java)
>         at org.apache.tools.ant.Main.start(Main.java)
>         at org.apache.tools.ant.Main.main(Main.java)
>
> Total time: 0 seconds
>
> Anyhow, after much grief, I eventually worked out that the problem lies in
> jikes: unset ANT_OPTS=-Dbuild.compiler=jikes and I can rebuild and run
> properly.
>
> This is, well, irritating. I've wasted time on this today, but now I will
> know not to build Ant with Jikes. I would d/l a later version except I am
> using the latest 1.15 version.
>
> 1. has anyone else noticed this problem, which seems to be in the jikes
> code generation?
> 2. Can anyone else replicate the problem, now that I mention it?
>
> If either of those two conditions are met I will file a bug with the jikes
> team; get them fetching and building ant as one of their QA targets.

-- 
Cheers,

Pete

*------------------------------------------------------*
| Despite your efforts to be a romantic hero, you will |
| gradually evolve into a postmodern plot device.      |
*------------------------------------------------------*

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message