ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Magesh Umasankar" <umag...@rediffmail.com>
Subject Re: Ant 1.5 and the Java 2 Platform
Date Sun, 04 Nov 2001 16:17:54 GMT


On Sun, 04 Nov 2001 Steve Loughran wrote :
> but everyone is thorough about using reflection to 
> access post1.1 facilities

Not really - I don't see any reflection being used to 
find out if HashMap, ArrayList, etc. are available ;-)

Also rt.jar ships with FTPClient, FTPInputStream, etc. 
(part of sun.net package tree).  The FTP task, IIRC,  doesn't try to use this - I understand
that this package 
is not to be used by the general public ;-), but so is 
Sun's Base64Encoder not to be used.

> optional tasks today implicitly depend on java 1.2+ 
> (ex: JSPC needs jasper,
> which I believe is a 1.2+ jar.

Good point.

> I think it is important to support java 1.1, as it is 
> not only a target for
> apps, but some platforms are limited to java1.1 for 
> builds too. I dont know

Though I agree there may be some such platforms, nixing 
compatibility for Java 1.1 was voted for in Ant2.
Wont these platforms have had the same problems if
Ant2 is, say, being released in the next 3-6 months?

> What particular 1.2+ functionality were you thinking of?

Collections - though one can still get the Collections 
API separately to work with Java1.1.

Also, some com.sun.image.codec.jpeg classes!

Agreed, we can most often find Java1.1 alternatives (either 3rd party or Sun supplied) for
Java1.2 core 
libraries, but why must we keep doing it?  

Magesh

 


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message