ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jose Alberto Fernandez" <j_a_fernan...@yahoo.com>
Subject Re: assertion changes
Date Thu, 22 Nov 2001 11:35:10 GMT
From: "Stefan Bodewig" <bodewig@apache.org>

> On Thu, 22 Nov 2001, Jose Alberto Fernandez <j_a_fernandez@yahoo.com>
> wrote:
> 
> >     <javac requires="1.4" />
> >     <java requires="1.2" />
> 
> These are extremely difficult to assert for Ant in the presence of a
> fork attribute in <java> or using a compiler other than classic/modern
> in <javac>.
> 

True. But you could use this information in a warning message or as part of
the exception or error output:
    "The task required usage of JDK1.4 or later, please verify you are using the right JDK"
or something like that.

Jose Alberto



--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message