ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Brown" <brow...@ociweb.com>
Subject Re: assertion changes
Date Thu, 22 Nov 2001 14:15:24 GMT

----- Original Message -----
From: "Stefan Bodewig" <bodewig@apache.org>
To: <ant-dev@jakarta.apache.org>
Sent: Thursday, November 22, 2001 4:27 AM
Subject: Re: assertion changes


> On Thu, 22 Nov 2001, Jose Alberto Fernandez <j_a_fernandez@yahoo.com>
> wrote:
>
> >     <javac requires="1.4" />
> >     <java requires="1.2" />
>
> These are extremely difficult to assert for Ant in the presence of a
> fork attribute in <java> or using a compiler other than classic/modern
> in <javac>.
>

This is sort of addressed by the "source" attribute that was added to the
javac task recently.  If your code contains asserts and you compile with
1.2, 1.3, 1.4 or 1.1, the code will NOT compile unless you specify "-source
1.4" on the compiler's command line, and even that will only work with 1.4
of course.  All of that is independant of the proposed changes, which are
targetted at enabling assertions at runtime.




--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message