ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 4303] - Problem using ant to build jar file
Date Sat, 20 Oct 2001 06:47:06 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=4303>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=4303

Problem using ant to build jar file

steve_l@iseran.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |WORKSFORME



------- Additional Comments From steve_l@iseran.com  2001-10-19 23:47 -------
Thank you for your detailed bug report. The problem probably lies in the first 
few lines, in the phrase
    Unknown command "\..\bin\lcp.bat"
This is a warning sign that the ant configuration on your system is somehow 
broken, and cant find a batch file used to set up the initial classpath. Some 
redistributions of ant suffer from this problem, and of course the support 
calls come to us. Maybe Jboss has the same problem.

1. find out which ant.bat is first on your path. If it aint in a directory 
called bin with the file lcp.bat in it -delete it.

2. if you dont have an up to date version of ant, please grab version 1.4.1 
off our web site and do a reinstall. find all versions of ant.bat in your 
filesystem and remove them.

3. try it from a DOS prompt, instead of 4NT. although 4NT is supported, 
sometimes, well, it does.

4. If that doesnt work, reformat your hard disk.
 (humour, do not attempt)

I am going to close this as a config error. If you have an issue with that 
assessment after trying any three of the suggestions above, you can re-open 
it.

Mime
View raw message