ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Hatcher" <jakarta-...@ehatchersolutions.com>
Subject how to build/test Ant from CVS?
Date Thu, 04 Oct 2001 04:02:49 GMT
Still haven't ironed out the problem.... here's what I'm getting:

C:\jakarta\jakarta-ant>ant
run-single-test -Dtestcase=org.apache.tools.taskdefs.
optional.PropertyFileTest
Buildfile: build.xml

prepare:

check_for_optional_packages:

build:
     [copy] Copying 2 files to C:\jakarta\jakarta-ant\build\classes

compile-tests:

run-single-test:
    [junit] Testsuite: org.apache.tools.taskdefs.optional.PropertyFileTest
    [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec
    [junit]
    [junit]     Caused an ERROR
    [junit] org.apache.tools.taskdefs.optional.PropertyFileTest
    [junit] java.lang.ClassNotFoundException:
org.apache.tools.taskdefs.optional
.PropertyFileTest
    [junit]     at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
    [junit]     at java.security.AccessController.doPrivileged(Native
Method)
    [junit]     at
java.net.URLClassLoader.findClass(URLClassLoader.java:188)
    [junit]     at java.lang.ClassLoader.loadClass(ClassLoader.java:297)
    [junit]     at
sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:286)

    [junit]     at java.lang.ClassLoader.loadClass(ClassLoader.java:253)
    [junit]     at
org.apache.tools.ant.AntClassLoader.findBaseClass(AntClassLoa
der.java:945)
    [junit]     at
org.apache.tools.ant.AntClassLoader.loadClass(AntClassLoader.
java:808)
    [junit]     at java.lang.ClassLoader.loadClass(ClassLoader.java:253)
    [junit]     at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.
<init>(JUnitTestRunner.java:173)
    [junit]     at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTask.execut
eInVM(JUnitTask.java:558)
    [junit]     at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTask.execut
e(JUnitTask.java:403)
    [junit]     at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTask.execut
e(JUnitTask.java:380)
    [junit]     at org.apache.tools.ant.Task.perform(Task.java:217)
    [junit]     at org.apache.tools.ant.Target.execute(Target.java:164)
    [junit]     at org.apache.tools.ant.Target.performTasks(Target.java:182)
    [junit]     at
org.apache.tools.ant.Project.executeTarget(Project.java:601)
    [junit]     at
org.apache.tools.ant.Project.executeTargets(Project.java:560)

    [junit]     at org.apache.tools.ant.Main.runBuild(Main.java:454)
    [junit]     at org.apache.tools.ant.Main.start(Main.java:153)
    [junit]     at org.apache.tools.ant.Main.main(Main.java:176)
    [junit]

BUILD FAILED

C:\jakarta\jakarta-ant\build.xml:752: Test
org.apache.tools.taskdefs.optional.Pr
opertyFileTest failed

Total time: 2 seconds

Here's my envrironment (from a setenv.bat I created):

set ant_home=c:\ant
set classpath=
set path=c:\ant\bin

This seems to mirror the configuration Levi posted.   And yes,
PropertyFileTest.class exists in the right place :)

It seems odd to me to run the 1.4 version of Ant though.   Shouldn't I run
with no classpath, no path, and no ant_home set using build.bat?   Like
this:

    build
run-single-test -Dtestcase=org.apache.tools.taskdefs.optional.PropertyFileTe
st

I'm getting the same error in both cases.   Any ideas what I'm doing wrong?

I'm sure I'm doing something stupid, I just don't see it yet.

Thanks
    Erik "not feeling like an Ant jGuru today" Hatcher



Mime
View raw message