ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glenn McAllister <gl...@somanetworks.com>
Subject Re: setZipFile(), setJarFile(), setWarFile --> setFile()
Date Wed, 12 Sep 2001 12:54:50 GMT
Peter Donald wrote:

> Hi,
>
> What does everyone think about using consistent naming on the zip related
> tasks. Currently subclasses add another method that just calls setZipFile().
> Wouldn't it be better to have a single method setFile() that is used in all
> subclasses. We could deprecate the old name and give warnings on use and
> recomend new plain file="" attribute ???

+1

Glenn McAllister
SOMA Networks, Inc.

Mime
View raw message