ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 3045] - Javac needs assert enabler for JDK1.4
Date Mon, 17 Sep 2001 18:01:21 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3045>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3045





------- Additional Comments From bholcombe@3veni.com  2001-09-17 11:01 -------
The javadoc task has a problem with asserts in Java 1.4 code. When running the 
javadoc task on code with assertions (code that works with the new javac task. 
Thanks!), I get errors like the following:

  [javadoc] ControlManager.java:24: ';' expected
  [javadoc]   assert ( newModels != null ) : "must have a non-null model";
  [javadoc]                                ^

My understanding from a JavaOne session is that javadoc now uses the javac 
compiler to generate its internal parse tree. If that javac doesn't have the 
"-source 1.4" passed through to it, you get the errors above. There is a new 
command line switch to support this. From the JDK1.4 tools docs:

-source 1.4 
     Necessary to enable javadoc to handle assertions present in J2SE v 1.4 
source code. This option documents code that compiles using "javac -source 1.4" 

I mentioned the JUnit task only because I thought it might have related 
problems, not because I had anything specific. My fault. Sorry for the 
confusion.

Brad
bholcombe@3veni.com

Mime
View raw message