ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefano Mancarella" <mancare...@opoipi.bancaintesa.it>
Subject [PATCH] <ear> and <war> with update="true"
Date Tue, 11 Sep 2001 09:08:01 GMT
Both <ear> and <war> have a required attribute ("appxml" for
ear and "webxml" for war).
If think this attributes shouldn't be required when you are
making an update, otherwise you are forced to re-specify an
appxml/webxml, even if it is already present in the archive.
My patch makes appxml/webxml required only if update is set
to "false" (which is the default).
If you set update="true", appxml/webxml is not required
anymore.
The patch is non-breaking (i.e. backwards compatibile).
The diff files are against Ant 1.4.
Please let me know if this patch is useful.

Thanks.

Mime
View raw message