ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Hoppe <ho...@sitewaerts.de>
Subject 1.4Beta2: NullpointerException in Commandline.quoteArgument
Date Thu, 23 Aug 2001 08:23:10 GMT
Hi list,

yesterday I downloaded 1.4Beta2 and I run into a problem with the following
build.xml:

<?xml version="1.0"?>
<project name="futuna" default="cc" basedir="../..">
	<property file="build/thisconfig/as.properties" />
	<property file="build/thisconfig/db.properties" />
	<property file="build/thisconfig/user.properties" />
	<property file="deployment.properties"/>
	<path id="base_classpath">
		<pathelement path="/bin/client/fbs_cc_finstral_wl61.jar"/>
		<pathelement path="/bin/client/jbcl3.1.jar"/>
		<pathelement path="/bin/client/jdom.jar"/>
		<pathelement path="/bin/client/log4j.jar"/>
		<pathelement path="/bin/client/werken.opt.jar"/>
		<pathelement path="/bin/client/werken.xpath.jar"/>
		<pathelement path="/bin/client/wlreduced.jar"/>
	</path>
	<target name="init">
	</target>
	
	<target name="cc" depends="init">
		<java
classname="de.sitewaerts.futuna.ccapplication.fis.Start" fork="true"
maxmemory="150m">
			<classpath>
				<path refid="base_classpath" />
			</classpath>
			<jvmarg value="-Dfbs.assystemname=wl61"/>
			<jvmarg
value="-Djavax.xml.parsers.DocumentBuilderFactory=weblogic.apache.xerces.jax
p.DocumentBuilderFactoryImpl"/>
			<arg value="--principal" />
			<arg value="${user}" />
			<arg value="--credentials" />
			<arg value="${user}" />
			<arg value="--deployment" />
			<arg value="${deployment}" />
			<arg value="--url" />
			<arg value="t3://127.0.0.1:7001" />
		</java>
	</target>
</project>

This is the ant -verbose output coming from this file:

[fbs3] C:\dev\hoppe\fbs3\build>av cc
Ant version 1.4Beta2 compiled on August 20 2001
Buildfile: thisconfig\cc.xml
Detected Java version: 1.3 in: c:\programme\jdk1.3.1\jre
Detected OS: Windows 2000
parsing buildfile C:\dev\hoppe\fbs3\build\thisconfig\cc.xml with URI =
file:C:/dev/hoppe/fbs3/build/thisconfig/cc.xml
Project base dir set to: C:\dev\hoppe\fbs3
 [property] Loading C:\dev\hoppe\fbs3\build\thisconfig\as.properties
 [property] Loading C:\dev\hoppe\fbs3\build\thisconfig\db.properties
 [property] Loading C:\dev\hoppe\fbs3\build\thisconfig\user.properties
 [property] Loading C:\dev\hoppe\fbs3\deployment.properties
Build sequence for target `cc' is [init, cc]
Complete build sequence is [init, cc]

init:

cc:

BUILD FAILED

java.lang.NullPointerException
        at
org.apache.tools.ant.types.Commandline.quoteArgument(Commandline.java:273)
        at
org.apache.tools.ant.types.Commandline.toString(Commandline.java:296)
        at
org.apache.tools.ant.types.CommandlineJava.toString(CommandlineJava.java:265
)
        at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:113)
        at org.apache.tools.ant.taskdefs.Java.execute(Java.java:88)
        at org.apache.tools.ant.Task.perform(Task.java:217)
        at org.apache.tools.ant.Target.execute(Target.java:164)
        at org.apache.tools.ant.Target.performTasks(Target.java:182)
        at org.apache.tools.ant.Project.executeTarget(Project.java:601)
        at org.apache.tools.ant.Project.executeTargets(Project.java:560)
        at org.apache.tools.ant.Main.runBuild(Main.java:454)
        at org.apache.tools.ant.Main.start(Main.java:153)
        at org.apache.tools.ant.Main.main(Main.java:176)

Total time: 1 second

With my own CVS builld dated July 20th 2001 the problem does not occur. Any
ideas?

Daniel

<<<<<<<<<<<<<<<<<<<<<<<<<<<
sitewaerts GmbH
Hebelstra├če 15
D-76133 Karlsruhe

Tel: +49 (721) 920 918 0
Fax: +49 (721) 920 918 29
http://www.sitewaerts.de
>>>>>>>>>>>>>>>>>>>>>>>>>>>



Mime
View raw message