ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [DO NOT REPLY: Bug 3334] CreateProcess broken on 1.4beta2/Win2k?
Date Wed, 29 Aug 2001 13:02:38 GMT
PLEASE DO NOT REPLY TO THIS MESSAGE. TO FURTHER COMMENT
ON THE STATUS OF THIS BUG PLEASE FOLLOW THE LINK BELOW
AND USE THE ON-LINE APPLICATION. REPLYING TO THIS MESSAGE
DOES NOT UPDATE THE DATABASE, AND SO YOUR COMMENT WILL
BE LOST SOMEWHERE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3334

*** shadow/3334	Wed Aug 29 05:49:45 2001
--- shadow/3334.tmp.370	Wed Aug 29 06:02:38 2001
***************
*** 2,8 ****
  | CreateProcess broken on 1.4beta2/Win2k?                                    |
  +----------------------------------------------------------------------------+
  |        Bug #: 3334                        Product: Ant                     |
! |       Status: RESOLVED                    Version: 1.4Beta2                |
  |   Resolution: WORKSFORME                 Platform: PC                      |
  |     Severity: Normal                   OS/Version: Other                   |
  |     Priority: Other                     Component: Core                    |
--- 2,8 ----
  | CreateProcess broken on 1.4beta2/Win2k?                                    |
  +----------------------------------------------------------------------------+
  |        Bug #: 3334                        Product: Ant                     |
! |       Status: RESOLVED                    Version: 1.3                     |
  |   Resolution: WORKSFORME                 Platform: PC                      |
  |     Severity: Normal                   OS/Version: Other                   |
  |     Priority: Other                     Component: Core                    |
***************
*** 46,49 ****
  ------- Additional Comments From wolf.siberski@tui.de  2001-08-29 05:49 -------
  This seems to be a quotation mark problem. Check if your
  property ss.dir already contains quotes (i.e. is set
! to <"c:\program files\..."> instead of <c:\program files\...>).
--- 46,75 ----
  ------- Additional Comments From wolf.siberski@tui.de  2001-08-29 05:49 -------
  This seems to be a quotation mark problem. Check if your
  property ss.dir already contains quotes (i.e. is set
! to <"c:\program files\..."> instead of <c:\program files\...>).
! 
! ------- Additional Comments From mplr@oce.nl  2001-08-29 06:02 -------
! I've thought about the quotes and have re-tried. It didn't happen until I 
! installed Java 1.4 beta 2 (build 1.4.0-beta-b65). My Ant version is 1.3 (I 
! changed the version in the bug info, I had selected the 1.4-2 because of my 
! java env).
! 
! To check the error I made a simple Java program using Runtime.exec and the path 
! to ss.exe. Worked perfectly. I'm not sure if it is a bug in the JDK or in Ant.
! 
!      [echo] ss.dir=<c:/Program Files/Microsoft Visual Studio/Common/VSS/win32>
! Execute:Java13CommandLauncher: "c:\Program Files\Microsoft Visual 
! Studio\Common\VSS\win32\ss" Get $/
! Nova/src -GLD:\Projects\nova\src -I- -R
! 
! BUILD FAILED
! 
! D:\Projects\nova\build.xml:164: java.io.IOException: CreateProcess: 
! c:\Program" "Files\Microsoft" "V
! isual" "Studio\Common\VSS\win32\ss Get $/Nova/src -GLD:\Projects\nova\src -I- -
! R error=123
! --- Nested Exception ---
! java.io.IOException: CreateProcess: 
! c:\Program" "Files\Microsoft" "Visual" "Studio\Common\VSS\win32\
! ss Get $/Nova/src -GLD:\Projects\nova\src -I- -R error=123
!         at java.lang.Win32Process.create(Native Method)

Mime
View raw message