ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [DO NOT REPLY: Bug 3217] New: Not really a bug, but a gotcha when running ant after IBM VAJ is installed
Date Wed, 22 Aug 2001 02:33:57 GMT
PLEASE DO NOT REPLY TO THIS MESSAGE. TO FURTHER COMMENT
ON THE STATUS OF THIS BUG PLEASE FOLLOW THE LINK BELOW
AND USE THE ON-LINE APPLICATION. REPLYING TO THIS MESSAGE
DOES NOT UPDATE THE DATABASE, AND SO YOUR COMMENT WILL
BE LOST SOMEWHERE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3217

*** shadow/3217	Tue Aug 21 19:33:57 2001
--- shadow/3217.tmp.6811	Tue Aug 21 19:33:57 2001
***************
*** 0 ****
--- 1,31 ----
+ +============================================================================+
+ | Not really a bug, but a gotcha when running ant after IBM VAJ is installed |
+ +----------------------------------------------------------------------------+
+ |        Bug #: 3217                        Product: Ant                     |
+ |       Status: NEW                         Version: 1.3                     |
+ |   Resolution:                            Platform: PC                      |
+ |     Severity: Normal                   OS/Version: Other                   |
+ |     Priority: Other                     Component: Wrapper scripts         |
+ +----------------------------------------------------------------------------+
+ |  Assigned To: ant-dev@jakarta.apache.org                                   |
+ |  Reported By: scottweaver@cinci.rr.com                                     |
+ |      CC list: Cc:                                                          |
+ +----------------------------------------------------------------------------+
+ |          URL:                                                              |
+ +============================================================================+
+ |                              DESCRIPTION                                   |
+ This really isn't a bug so much as something to watch out for, a "gotcha" if 
+ you will.  When installing IBM VisualAge for Java Enterprise, this entry is 
+ added to the classpath: C:\IBM Connectors\classes.  The problem here in lies 
+ with the fact that VAJ adds it without " " around the entry which contains 
+ blank spaces.  When running the ant.bat I kept getting a NoClassDefinitionFound 
+ exception.  It took me a half an hour to notice the blank space in the system 
+ classpath and subsequently put the requisite " " around the entry.  This fixed 
+ the problem and the ant test ran fine.  
+ 
+ This maybe something you might want to add to the documentation just help 
+ developers avoid confusion and the mandatory banging of the head against the 
+ proverbeal wall.
+ 
+ Regards,
+ Scott T. Weaver

Mime
View raw message