ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [DO NOT REPLY: Bug 3158] "java" task has got problems with loading classes
Date Sun, 19 Aug 2001 06:26:50 GMT
PLEASE DO NOT REPLY TO THIS MESSAGE. TO FURTHER COMMENT
ON THE STATUS OF THIS BUG PLEASE FOLLOW THE LINK BELOW
AND USE THE ON-LINE APPLICATION. REPLYING TO THIS MESSAGE
DOES NOT UPDATE THE DATABASE, AND SO YOUR COMMENT WILL
BE LOST SOMEWHERE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3158

*** shadow/3158	Fri Aug 17 09:49:47 2001
--- shadow/3158.tmp.9083	Sat Aug 18 23:26:50 2001
***************
*** 19,22 ****
  java.lang.NoClassDefFoundError is thrown. i double-checked that the class is in 
  the classpath. the strange thing is when i emulate the java task by an exec 
  task (running java.exe "by hand"), everything works fine.
! this problem has been present at least since ant 1.3 final.
--- 19,28 ----
  java.lang.NoClassDefFoundError is thrown. i double-checked that the class is in 
  the classpath. the strange thing is when i emulate the java task by an exec 
  task (running java.exe "by hand"), everything works fine.
! this problem has been present at least since ant 1.3 final.
! 
! ------- Additional Comments From conor@cortexebusiness.com.au  2001-08-18 23:26 -------
! This sort of behaviour can usually be explained or investigated but we will 
! need more information. We need to know your system classpath, the classpath you 
! are using with your Java task and even the ant-debug output which will show the 
! activity of the Ant classloader.

Mime
View raw message