ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [DO NOT REPLY: Bug 3158] New: "java" task has got problems with loading classes
Date Fri, 17 Aug 2001 16:49:47 GMT
PLEASE DO NOT REPLY TO THIS MESSAGE. TO FURTHER COMMENT
ON THE STATUS OF THIS BUG PLEASE FOLLOW THE LINK BELOW
AND USE THE ON-LINE APPLICATION. REPLYING TO THIS MESSAGE
DOES NOT UPDATE THE DATABASE, AND SO YOUR COMMENT WILL
BE LOST SOMEWHERE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=3158

*** shadow/3158	Fri Aug 17 09:49:47 2001
--- shadow/3158.tmp.19385	Fri Aug 17 09:49:47 2001
***************
*** 0 ****
--- 1,22 ----
+ +============================================================================+
+ | "java" task has got problems with loading classes                          |
+ +----------------------------------------------------------------------------+
+ |        Bug #: 3158                        Product: Ant                     |
+ |       Status: NEW                         Version: 1.4Beta1                |
+ |   Resolution:                            Platform: PC                      |
+ |     Severity: Normal                   OS/Version: Windows NT/2K           |
+ |     Priority: Other                     Component: Core tasks              |
+ +----------------------------------------------------------------------------+
+ |  Assigned To: ant-dev@jakarta.apache.org                                   |
+ |  Reported By: andreas@schildba.ch                                          |
+ |      CC list: Cc:                                                          |
+ +----------------------------------------------------------------------------+
+ |          URL:                                                              |
+ +============================================================================+
+ |                              DESCRIPTION                                   |
+ when i use the java task to execute a class, i frequently have got problems to 
+ load classes. for example: when i do a Class.forName(), a 
+ java.lang.NoClassDefFoundError is thrown. i double-checked that the class is in 
+ the classpath. the strange thing is when i emulate the java task by an exec 
+ task (running java.exe "by hand"), everything works fine.
+ this problem has been present at least since ant 1.3 final.

Mime
View raw message