ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@cortexebusiness.com.au>
Subject Re: [GUMP] Test Failure - Ant
Date Tue, 21 Aug 2001 12:56:03 GMT
I don't remember where I found xslp. My primary motivation was to get
<available> to build the Liaison class. I didn't actually use it :-)

Anyway, I have built the 1.1 version and now my test run gives

Testcase:
testEncoding(org.apache.tools.ant.taskdefs.optional.XslpLiaisonTest)::
Caused an ERROR
The root element is required in a well-formed document.
org.xml.sax.SAXParseException: The root element is required in a
well-formed document.
        at org.apache.xerces.framework.XMLParser.reportError(Unknown
Source)
        at
org.apache.xerces.framework.XMLDocumentScanner.reportFatalXMLError(Unknown
Source)
        at
org.apache.xerces.framework.XMLDocumentScanner$XMLDeclDispatcher.endOfInput
(Unknown Source)
        at
org.apache.xerces.framework.XMLDocumentScanner.endOfInput(Unknown Source)
        at
org.apache.xerces.validators.common.XMLValidator.sendEndOfInputNotification
s(Unknown Source)
        at
org.apache.xerces.readers.DefaultEntityHandler.changeReaders(Unknown
Source)

It appears the transformed files are zero length.

Conor


----- Original Message -----
From: "Stephane Bailliez" <sbailliez@imediation.com>
To: <ant-dev@jakarta.apache.org>
Sent: Tuesday, August 21, 2001 10:05 PM
Subject: RE: [GUMP] Test Failure - Ant



Where did you get xslp ?
It looks like an error because it xslp 1.0 instead of 1.1

You have to get it from cvs...
http://www.clc-marketing.com/xslp/cvs.html

I'm +1E99999999 to remove xslp for 1.5

When I rewrote the liaison interface I noticed that XSLP was issuing a
NullPointerException because the XSLP static properties were never
initialized. So all in all I don't think it was ever run one day.

--
 St├ęphane Bailliez
 Software Engineer, Paris - France
 iMediation - http://www.imediation.com
 Disclaimer: All the opinions expressed above are mine and not those from
my
company.



> -----Original Message-----
> From: Conor MacNeill [mailto:conor@cortexebusiness.com.au]
> Sent: Tuesday, August 21, 2001 1:48 PM
> To: ant-dev@jakarta.apache.org
> Subject: Re: [GUMP] Test Failure - Ant
>
>
> Stephane,
>
> I have tested with 1.3.0 and the test passes. Interestingly
> the XSLP test
> fails thus
> Testsuite: org.apache.tools.ant.taskdefs.optional.XslpLiaisonTest
> Tests run: 2, Failures: 0, Errors: 2, Time elapsed: 0.441 sec
>
> Testcase:
> testTransform(org.apache.tools.ant.taskdefs.optional.XslpLiais
> onTest)::
> Caused an ERROR
> null
> java.lang.NoSuchMethodError
>         at
> com.kvisco.xml.parser.XercesParser.init(XercesParser.java:63)
>         at
> com.kvisco.xml.parser.XercesParser.<init>(XercesParser.java:53)
>
> I believe this is because the XercesParser class calls
> setValidating on
> DOMParser. I guess this is out of date - it was
> setValidating() in Xerces
> 1.0.0 and is now setValidation(). It will be impossible to
> test these two
> together.
>
> When I took the xslp jar out, everything started to pass with
> all versions
> of Xerces. Not sure if there is something going on in the VM
> due to the
> different signatures of the references to the Xerces classes.
> I wouldn't
> think so but who knows? I think we should probably deprecate
> the "xslp"
> value for processor, and then remove support for it for Ant
> 1.5+. Would
> that be an issue?
>
> This is unlikely to be the issue for the Gump failure, however.
>
> Conor
>
> ----- Original Message -----
> From: "Stephane Bailliez" <sbailliez@imediation.com>
> To: <ant-dev@jakarta.apache.org>
> Sent: Tuesday, August 21, 2001 5:43 PM
> Subject: RE: [GUMP] Test Failure - Ant
>
>
> I have been using Xerces 1.4.2 and Xerces 1.3.0 as far as i remember.
> Will try at work. I need some time to update everything and
> will try to
> look
> at xerces cvs to see if there's something here.
>
>
>
>



Mime
View raw message