ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Introspection Change comments
Date Wed, 01 Aug 2001 06:26:07 GMT
On Wed, 1 Aug 2001, Conor MacNeill <conor@cortexebusiness.com.au>
wrote:

> I have implemented this (the diff is attached), by checking for a
> method addConfiguredXXX, rather than simply addXXX.

+1

> Now, my main concern is with the use of addConfigured. It is
> potentially a compatibility issue if some custom task has a nested
> element <configured...>.

You'd run the same risk for each and every naming convention you could
come up with.  Add a warning to WHATSNEW and that's it.

> So, what do you think? It makes some tasks easier to write if the
> element is configured before it is added to the task.

It certainly does, the current system has been there as addX and
createX have been supposed to be as close as possible, I can't
remember why ...

Stefan

Mime
View raw message