ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 2907] New: - Annoying "...does'nt exist" message in log file
Date Mon, 30 Jul 2001 23:46:00 GMT
PLEASE DO NOT REPLY TO THIS MESSAGE. TO FURTHER COMMENT
ON THE STATUS OF THIS BUG PLEASE FOLLOW THE LINK BELOW
AND USE THE ON-LINE APPLICATION. REPLYING TO THIS MESSAGE
DOES NOT UPDATE THE DATABASE, AND SO YOUR COMMENT WILL
BE LOST SOMEWHERE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=2907

*** shadow/2907	Mon Jul 30 16:46:00 2001
--- shadow/2907.tmp.1055	Mon Jul 30 16:46:00 2001
***************
*** 0 ****
--- 1,42 ----
+ +============================================================================+
+ | Annoying "...does'nt exist" message in log file                            |
+ +----------------------------------------------------------------------------+
+ |        Bug #: 2907                        Product: Ant                     |
+ |       Status: NEW                         Version: 1.3                     |
+ |   Resolution:                            Platform: PC                      |
+ |     Severity: Minor                    OS/Version: Windows NT/2K           |
+ |     Priority: Other                     Component: Core tasks              |
+ +----------------------------------------------------------------------------+
+ |  Assigned To: ant-dev@jakarta.apache.org                                   |
+ |  Reported By: vineet_bhatia@ocs.com                                        |
+ |      CC list: Cc:                                                          |
+ +----------------------------------------------------------------------------+
+ |          URL:                                                              |
+ +============================================================================+
+ |                              DESCRIPTION                                   |
+ All the tasks work fine, but, I keep getting these annoying messages in the log 
+ file (verbose). Used to work fine with 1.2.
+ 
+ "[javac] pkg\subpkg\Somefile.java added as 
+ C:\correct\path\to\class\file\pkg\subpkg\Somefile.class doesn't exist." 
+ 
+ I get similar messages for <copy> and <delete> tasks.
+ 
+ "[copy] pkg\sub\pkg\xyz.class added as C:\some\path\pkg\sub\pkg\xyz.class 
+ doesn't exist."
+ 
+ etc..
+ 
+ Task XML - 
+ <target name="tskname" depends="init">
+     <mkdir dir="${xxx.classbindir}"/>
+     <javac srcdir="${some.src}"
+     	   includes="some/pkg/subpkg1/**,some/pkg/subpkg2/*.some/pkg/subpkg3/**"
+ 	   
+            destdir="${xxx.classbindir}"
+            classpath="${some.classpath}"/>
+ </target>
+ 
+ <copy todir="${some.buildjardir}">
+     <fileset dir="${some.classbindir}"/>
+ </copy>

Mime
View raw message