ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 2906] New: - would like to see proper version supporting jar files included into binary/src distributions
Date Mon, 30 Jul 2001 21:52:41 GMT
PLEASE DO NOT REPLY TO THIS MESSAGE. TO FURTHER COMMENT
ON THE STATUS OF THIS BUG PLEASE FOLLOW THE LINK BELOW
AND USE THE ON-LINE APPLICATION. REPLYING TO THIS MESSAGE
DOES NOT UPDATE THE DATABASE, AND SO YOUR COMMENT WILL
BE LOST SOMEWHERE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=2906

*** shadow/2906	Mon Jul 30 14:52:41 2001
--- shadow/2906.tmp.845	Mon Jul 30 14:52:41 2001
***************
*** 0 ****
--- 1,39 ----
+ +============================================================================+
+ | would like to see proper version supporting jar files included into binary |
+ +----------------------------------------------------------------------------+
+ |        Bug #: 2906                        Product: Ant                     |
+ |       Status: NEW                         Version: Nightly build           |
+ |   Resolution:                            Platform: Sun                     |
+ |     Severity: Enhancement              OS/Version: Solaris                 |
+ |     Priority: Other                     Component: Build Process           |
+ +----------------------------------------------------------------------------+
+ |  Assigned To: ant-dev@jakarta.apache.org                                   |
+ |  Reported By: asokol@edocs.com                                             |
+ |      CC list: Cc:                                                          |
+ +----------------------------------------------------------------------------+
+ |          URL:                                                              |
+ +============================================================================+
+ |                              DESCRIPTION                                   |
+ As found on nightly binary/src distribution as of July 27th, 2001:
+ 
+ junit report target in optional.jar depends on several xalan libraries. The 
+ following distribution problem was observed:
+ 
+ If binary dist is downloaded, xalan jars are not included in it. When xalan is 
+ downloaded separately - its only available version at the time (xalan-j_2_2_D6) 
+ did not match the ant/optional.jar build and caused junitreport target 
+ execution to crush. 
+ 
+ If source distribution is downloaded, it would work once rebuild, except 
+ build.sh needed to be modified by hand to append xalanj1compat.jar to 
+ LOCALCLASSPATH. Also, more xalan jars are in fact required to run junitreport 
+ although Ant Manual documentation seem to imply that only compatibility jar is 
+ needed...
+ 
+ To summarize:
+ 
+ 1) binary distributions of optional tasks should include complete set of 
+ matching jars needed to execute such tasks
+ 
+ 2) source distributions should fix documentaion/build.sh and point to proper 
+ version of supporting product distributions

Mime
View raw message