ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 1326] New - "ant -find -projecthelp" fails, even in build file directory
Date Thu, 12 Apr 2001 20:21:41 GMT
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=1326

*** shadow/1326	Thu Apr 12 13:21:41 2001
--- shadow/1326.tmp.26187	Thu Apr 12 13:21:41 2001
***************
*** 0 ****
--- 1,93 ----
+ +============================================================================+
+ | "ant -find -projecthelp" fails, even in build file directory               |
+ +----------------------------------------------------------------------------+
+ |        Bug #: 1326                        Product: Ant                     |
+ |       Status: NEW                         Version: 1.3                     |
+ |   Resolution:                            Platform: PC                      |
+ |     Severity: Normal                   OS/Version:                         |
+ |     Priority:                           Component: Other                   |
+ +----------------------------------------------------------------------------+
+ |  Assigned To: ant-dev@jakarta.apache.org                                   |
+ |  Reported By: Daniel.Barclay@digitalfocus.com                              |
+ |      CC list: Cc:                                                          |
+ +----------------------------------------------------------------------------+
+ |          URL:                                                              |
+ +============================================================================+
+ |                              DESCRIPTION                                   |
+ The command "ant -find -projecthelp" fails, even when executed in the
+ directory containing the build file (build.xml).
+ 
+ Note that "ant -projectfile -find" does work.
+ 
+ 
+ 
+ TEST CASE (with my output):
+ 
+ See the fourth invocation of Ant ("ant -find -projecthelp").
+ (Ignore errors for the missing target.)
+ 
+ (This is under CygWin 1.1.x on Windows NT.)
+ 
+ bash-2.04$ mkdir test
+ bash-2.04$ cd test
+ bash-2.04$ ls
+ bash-2.04$ cat >build.xml <<EOF
+ > <project default="never mind no target"/>
+ > EOF
+ bash-2.04$ ant 
+ Buildfile: build.xml
+ 
+ BUILD FAILED
+ 
+ Target `never mind no target' does not exist in this project. 
+ 
+ Total time: 0 seconds
+ bash-2.04$ ant -projecthelp
+ Buildfile: build.xml
+ Main targets:
+ 
+ 
+ Subtargets:
+ 
+ 
+ 
+ BUILD SUCCESSFUL
+ 
+ Total time: 0 seconds
+ bash-2.04$ ant -projecthelp -find
+ Searching for build.xml ...
+ Buildfile: C:\Daniel\Projects\AntLearning\temp\test\.\build.xml
+ Main targets:
+ 
+ 
+ Subtargets:
+ 
+ 
+ 
+ BUILD SUCCESSFUL
+ 
+ Total time: 0 seconds
+ bash-2.04$ ant -find -projecthelp
+ Searching for -projecthelp ...
+ Could not locate a build file!
+ bash-2.04$ mkdir subdir
+ bash-2.04$ cd subdir
+ bash-2.04$ ant -find -projecthelp
+ Searching for -projecthelp ...
+ Could not locate a build file!
+ bash-2.04$ ant -projecthelp -find
+ Searching for build.xml ...
+ Buildfile: C:\Daniel\Projects\AntLearning\temp\test\build.xml
+ Main targets:
+ 
+ 
+ Subtargets:
+ 
+ 
+ 
+ BUILD SUCCESSFUL
+ 
+ Total time: 0 seconds
+ bash-2.04$ ant -projecthelp 
+ Buildfile: build.xml does not exist!
+ Build failed

Mime
View raw message