ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@cortexebusiness.com.au>
Subject RE: Can't compile from scratch.
Date Wed, 14 Mar 2001 01:32:48 GMT
Jesse,

> From: jglick@sunpraha.Czech.Sun.COM
>
> By the way Ant buildscript developers: it would be desirable if Ant itself
> could always be built using the last released version. This was
> not the case
> between 1.2 and 1.3.
>

Why?

That would mean that features added to ant could not be used in Ant's own
buildfile. For example, in Ant 1.3, we would not have been able to build tar
files with long filenames and appropriate execute permissions.

Ant will always be buildable by the current version (via bootstrapping). I
do not think we should require the latest version to always be buildable by
the previous release. The converse is true, however.

Conor


---------------------------------------------------------------------
To unsubscribe, e-mail: ant-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: ant-dev-help@jakarta.apache.org


Mime
View raw message