ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Burton" <bi...@progress.com>
Subject Re: [PATCH] modifications to ant shell script to run under cygwin
Date Wed, 21 Feb 2001 19:02:21 GMT
Hello,

It turns out no modification is required to the 1.3 ant shell script as
the current test in the script also works for Cygwin running on Windows
98.

-Bill

Bill Burton wrote:
> 
> Hello Lucas,
> 
> Lucas Gonze wrote:
> >
> > that is a far cleaner approach than mine.  We should use it.
> >
> > But I see that your version of cygwin lists ostype as "CYGWIN_NT-5.0", while my
> > version cygwin on win98 lists ostype as "cygwin".  So that is a secondary bug.
> 
> Yes, that's a bug.  It also could be your version of Cygwin is older.
> What version are you running?
> 
> > I don't know shell syntax to match both of those expressions.  In java this would
be:
> > if( ostype.toLowerCase().indexOf("cygwin") == 0 ) {...}
> >
> > suggestions?
> 
> Try changing the line near the top from:
>   CYGWIN*) cygwin=true ;;
> to:
>   CYGWIN*|cygwin*) cygwin=true ;;
> 
> -Bill

Mime
View raw message