ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 603] New - The <style> task does not support absolute paths
Date Wed, 14 Feb 2001 10:39:58 GMT
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=603

*** shadow/603	Wed Feb 14 02:39:57 2001
--- shadow/603.tmp.19755	Wed Feb 14 02:39:58 2001
***************
*** 0 ****
--- 1,60 ----
+ +============================================================================+
+ | The <style> task does not support absolute paths                           |
+ +----------------------------------------------------------------------------+
+ |        Bug #: 603                         Product: Ant                     |
+ |       Status: NEW                         Version: 1.3 Beta 1              |
+ |   Resolution:                            Platform: PC                      |
+ |     Severity: Normal                   OS/Version: FreeBSD                 |
+ |     Priority: Medium                    Component: Core tasks              |
+ +----------------------------------------------------------------------------+
+ |  Assigned To: ant-dev@jakarta.apache.org                                   |
+ |  Reported By: ernst@jollem.com                                             |
+ |      CC list: Cc:                                                          |
+ +----------------------------------------------------------------------------+
+ |          URL:                                                              |
+ +============================================================================+
+ |                              DESCRIPTION                                   |
+ The <style> task does not seem to support absolute paths. When I use one, it
+ just prefixes the current path to it. I have specified
+ "/home/ernst/orion-tutorial/stylesheets/classic/classic.xsl" as the path to the
+ stylesheet, but when I run ant I get this error message:
+ 
+ bash-2.04$ ant
+ Buildfile: build.xml
+ 
+ init:
+ 
+ 2html:
+     [style] Transforming into /usr/home/ernst/orion-primer/build
+     [style] Loading stylesheet /usr/home/ernst/orion-primer/src/home/ernst/o
+ rion-tutorial/stylesheets/classic/classic.xsl
+     [style] Transforming into /usr/home/ernst/orion-primer/build
+ file:/usr/home/ernst/orion-primer/src/home/ernst/orion-tutorial/stylesheets/
+ classic/classic.xsl; Line -1; Column -1
+ XSL Error: Could not parse file:/usr/home/ernst/orion-primer/src/home/ernst/
+ orion-tutorial/stylesheets/classic/classic.xsl document!
+ XSL Error: SAX Exception
+     [style] Failed to process /usr/home/ernst/orion-primer/src/orion-primer.
+ xml
+ 
+ BUILD FAILED
+ 
+ Note that /home links to /usr/home.
+ 
+ My build.xml file is very straightforward:
+ 
+    <target name="init">
+       <property name="stylesheet"
+ value="/home/ernst/orion-tutorial/stylesheets/classic/classic.xsl" />
+    </target>
+ 
+    <target name="2html" depends="init">
+       <style basedir="src"
+              destdir="build"
+              style="${stylesheet}"
+              includes="orion-primer.xml"
+       />
+    </target>
+ 
+ I ran into this problem with 1.2. I checked 1.3 beta 1 and the bug database
+ before committing it.

Mime
View raw message