ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 420] New - dir attribute on <exec> not working BugRat Report#727
Date Thu, 01 Feb 2001 09:51:01 GMT
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=420

*** shadow/420	Thu Feb  1 01:51:00 2001
--- shadow/420.tmp.8716	Thu Feb  1 01:51:00 2001
***************
*** 0 ****
--- 1,43 ----
+ +============================================================================+
+ | dir attribute on <exec> not working BugRat Report#727                      |
+ +----------------------------------------------------------------------------+
+ |        Bug #: 420                         Product: Ant                     |
+ |       Status: UNCONFIRMED                 Version: 1.2                     |
+ |   Resolution:                            Platform: All                     |
+ |     Severity: Normal                   OS/Version: All                     |
+ |     Priority: High                      Component: Main                    |
+ +----------------------------------------------------------------------------+
+ |  Assigned To: ant-dev@jakarta.apache.org                                   |
+ |  Reported By: agoodno@yahoo.com                                            |
+ |      CC list: Cc:                                                          |
+ +----------------------------------------------------------------------------+
+ |          URL:                                                              |
+ +============================================================================+
+ |                              DESCRIPTION                                   |
+ I tested this task in response to the recent post by Eoin Whelan with the subject "RE: Dir
attribute of the execute task."
+ 
+ The dir attribute is ignored in the following exec task.
+ 
+ <exec dir="D:\Temp" executable="Cartman"/>
+ 
+ The error I get is:
+ 
+ D:\IT\Dev\Apps\TransView\build_test.xml:99: Execute failed: java.io.IOException: CreateProcess:
Cartman error=2
+ java.io.IOException: CreateProcess: Cartman error=2
+         at java.lang.Win32Process.create(Native Method)
+         at java.lang.Win32Process.<init>(Win32Process.java:66)
+         at java.lang.Runtime.execInternal(Native Method)
+         at java.lang.Runtime.exec(Runtime.java:551)
+         at java.lang.reflect.Method.invoke(Native Method)
+         at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:393)
+         at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:249)
+         at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:214)
+         at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:154)
+         at org.apache.tools.ant.Target.execute(Target.java:142)
+         at org.apache.tools.ant.Project.runTarget(Project.java:818)
+         at org.apache.tools.ant.Project.executeTarget(Project.java:532)
+         at org.apache.tools.ant.Project.executeTargets(Project.java:506)
+         at org.apache.tools.ant.Main.runBuild(Main.java:420)
+         at org.apache.tools.ant.Main.main(Main.java:149)
+ 
+ Total time: 2 seconds

Mime
View raw message