ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin van den Bemt" <m...@mvdb.com>
Subject RE: [FIX] ??? build.bat for windows 2000
Date Sat, 20 Jan 2001 10:06:19 GMT
It works for me though ;-)) I don't enter to much parameters, I must add.
But the current build.bat is pretty useless (it doesn't work at all) on win
2000 (at least when using cmd, didn't test this with command though.  The
problem is that build.bat itself passes some blah=blah parameters to ant.bat
which doesn't get passed in very well. If I do a build jars the parameter
will become ant (classpath) jars= and it runs great ;-))
I'll look into it if I can get it more "usefull" for everyone else (at least
if thats interesting enough. Preferably most of the stuff should be taken
care of in the build.xml  (if not all the stuff).
I'll see if I can fix it...

Mvgr,
Martin

-----Original Message-----
From: Nico Seessle [mailto:Nico.Seessle@epost.de]
Sent: Saturday, January 20, 2001 2:45 AM
To: ant-dev@jakarta.apache.org
Subject: Re: [FIX] ??? build.bat for windows 2000


----- Original Message -----
From: "Martin van den Bemt" <mvdb@mvdb.com>
To: "Antdev" <ant-dev@jakarta.apache.org>
Sent: Friday, January 19, 2001 8:52 PM
Subject: [FIX] ??? build.bat for windows 2000


> Gentleman,
>
> Did anyone check out my build.bat which I mailed earlier to ant-dev. The
> build.bat doesn't work on win2000 (at least not on mine), because it
treats
> value=value in the environment as 2 seperate cmd line parameters. I just
> adjusted it "lightly" and cannot test the jikes stuff in build.bat, but I
> can clean up the echoing if necessary.
> Also don't know if this build.bat works with other win versions. (don't
have
> them available here..)
>

I think your change doesn't even "work" on W2K either (depends on how you
define "work").

If I call it like this (I know -foo and -bar are not valid args, replace
them by what you like)
D:\temp>ant -verbose -foo -bar
I get:
command line :  -verbose=-foo
and this is simply wrong!

Windows is fucking bad with these things and the only solution I can think
of that works for all Versions W95++ is to call it like 'ant.bat
"-Dproperty=value" ...'.

Nico



---------------------------------------------------------------------
To unsubscribe, e-mail: ant-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: ant-dev-help@jakarta.apache.org



Mime
View raw message