ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephane Bailliez <sbaill...@imediation.com>
Subject RE: Ant 1.2 not compatible with JUnit 3.5
Date Fri, 26 Jan 2001 11:54:15 GMT

The only difference is the signature of the method addFailure in
TestListener.
Should be changed from:

public void addFailure(Test test, Throwable t) {}

to:
public void addFailure(Test test, AssertionFailedError t) {}

Cannot do it otherwise I will have to send too many changes due to my
current (prototyped) dev

impacted files are:
JUnitTestRunner
PlainJUnitResultFormatter
SummaryJUnitResultFormatter
XMLJUnitResultFormatter

-- 
 St├ęphane Bailliez 
 Software Engineer, Paris - France 
 iMediation - http://www.imediation.com 
 Disclaimer: All the opinions expressed above are mine and not those from my
company. 



> -----Original Message-----
> From: Stefan Bodewig [mailto:bodewig@apache.org]
> Sent: Friday, January 26, 2001 9:48 AM
> To: ant-dev@jakarta.apache.org
> Subject: Re: Ant 1.2 not compatible with JUnit 3.5
> 
> 
> Nico Seessle <Nico.Seessle@epost.de> wrote:
> 
> > Yes, this is a known problem. Only problem is that I'm not sure if
> > we should drop support for older versions completely and just adjust
> > it to the new interfaces?
> 
> I've not yet found time to look into it - how different is the new
> interface? Can we adjust the task in a way that it will work with 3.5
> _and_ earlier versions?
> 
> Anyway, 3.5 is the latest released version and I think Ant 1.3 should
> ship with a task that works with the latest release and not force
> users to downgrade JUnit. I'll take care of it next week (as my
> current project's deadline expires on Monday) - unless anybody is
> faster than me.
> 
> Stefan
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: ant-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: ant-dev-help@jakarta.apache.org
> 

Mime
View raw message