ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <dona...@apache.org>
Subject Re: [Coding Standards] Apache licence and GPL compatible?
Date Thu, 18 Jan 2001 20:24:26 GMT
At 01:09  18/1/01 +0000, Stuart Roebuck wrote:
>I've just had an email from Chris Seguin, the author of the code
reformatting 
utilities.  It looks to him that the GPL and Apache licenses are
incompatible.  

yep 100%. GPL can not use APL and APL can not use GPL. I heard that this
will change with APL1.3 and GPL3 but no one has been able to confirm or
deny this ;)

>I hasten to say that he goes on to say:
>
>> I might just start releasing it with a Apache license 
>> instead. 
>>  
>> Also, I'm excited!  I got Ant to work today!!!! 

You could ask him to dual license it (GPL/APL) or you could ask him to
place it under BSD (which both APL and GPL can use). 

Cheers,

Pete

*-----------------------------------------------------*
| "Faced with the choice between changing one's mind, |
| and proving that there is no need to do so - almost |
| everyone gets busy on the proof."                   |
|              - John Kenneth Galbraith               |
*-----------------------------------------------------*


Mime
View raw message