ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simeon H.K. Fitch" <sim...@fitch.net>
Subject Re: Ant 2 -> Java 1.2
Date Sun, 10 Dec 2000 01:28:27 GMT


Peter Donald wrote:

> What environment would that be? I don't know of any environment that
> doesn't have reasonable 1.2 support. 

HPUX 10.20. HP *will not* port Java 1.2 to that platform due to a broken
threading model (my uninformed analysis). You'd be surprised how many
people are stuck there and won't upgrade due the involved costs and
political issues (two of my customers are in this situation).

I just wanted to drop in this data point. Personally, I'm in the camp
that post Ant 1.3 we should make full use of Java 1.2 features and
require that platform as a minimum. I think Ant 1.3 would be perfectly
sufficient for people standed on the Java 1.1.x platform, myself being
one of them.

sim

Mime
View raw message