ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <dona...@apache.org>
Subject Re: Default libs included
Date Fri, 15 Dec 2000 09:15:02 GMT
At 10:39  14/12/00 -0800, Louis Tribble wrote:
>Peter Donald wrote:
>> 
>> Hi,
>> 
>> I have just gone through and updated a number of projects to use latest CVS
>> ant and realized that ant is almost ready to be deployed once per machine
>> rather than once per project. The few things that stop it are;
>> 
>> 1. $ANT_HOME has to be set due to limitations of win9x ;(
>> 2. lib dirs other than $ANT_HOME/lib should ideally auotmagically sucked
>> into classpath
>> 
>> I think we can fix 2 by an addition to the scripts. Basically suck in all
>> jars in ./lib just like we do for $ANT_HOME/lib. This is likeable because
>> it is very common pattern among different projects. 
>
>I don't think the patch posted by Vincent Bergbauer ever got applied.
>It seems to solve 1 for NT/2K. I've appended his message. (I haven't
>used it yet, but I've been saving it.)

thanks - I just checked it into CVS. Could someone on NT/2000 check that it
still works 100% ? Thanks 

Cheers,

Pete

*-----------------------------------------------------*
| "Faced with the choice between changing one's mind, |
| and proving that there is no need to do so - almost |
| everyone gets busy on the proof."                   |
|              - John Kenneth Galbraith               |
*-----------------------------------------------------*


Mime
View raw message