ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: rmic fails with jdk/1.3.0 from IBM
Date Wed, 29 Nov 2000 14:03:33 GMT
Peter Nordlund <peter.nordlund@lentus.se> wrote:

>  I downloaded 1.3.0 from IBM 17 nov 2000 and it fails.
>  I can run IBMs rmic manually on the command line, but from inside
>  ant it fails.

I have an older version

bodewig@bodewig ~/java/tests >java -version
java version "1.3.0"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.0)
Classic VM (build 1.3.0, J2RE 1.3.0 IBM build cx130-20000623 (JIT enabled: jitc))

and it seems to work for me - I don't have a package starting with
com.sun.corba either, neither in tools.jar nor in dt.jar or rt.jar.

The same class is not part of Sun's own JDK 1.3 for Linux either BTW,
there is a package com/sun/corba/se/idl but not
com/sun/corba/se/internal.

My best guess would be that comand line rmic doesn't use
sun.rmi.rmic.Main. Does "strings JAVA_HOME/bin/exe/rmic | grep Main"
give a result similar to mine?

bodewig@bodewig ~/tmp/rmic >strings /usr/local/java/jdk1.3/bin/exe/rmic | grep Main
Main-Class is '%s'
Failed to load Main-Class manifest attribute from
getMainAttributes
Main-Class
sun.rmi.rmic.Main

Stefan

Mime
View raw message