ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Nordlund <peter.nordl...@lentus.se>
Subject rmic fails with jdk/1.3.0 from IBM
Date Wed, 29 Nov 2000 08:34:02 GMT
 Hi,

 I sent the very same mail yesterday, but I screwed up the
 subject line so that it became somewhat misleading.

 So once again:
-----------------------------------------
 
 I have an rmic call which works ok with jdk/1.3.0 from sun
 
 I downloaded 1.3.0 from IBM 17 nov 2000 and it fails.
 I can run IBMs rmic manually on the command line, but from inside
 ant it fails.
 
 I dont know if this is a bug that should be reported to IBM or if
 you ant guys have any idea of what is going on?
 
 I have ant/1.2 and redhat 6.2
 --------------------------------
 Excerpt from my build.xml:
   <target name="rmic" depends="">
         <rmic
 classname="se.lentus.lentus.callback.ServerCallBackProxy"
          base="${lentus.build.classes}">
         </rmic>
         <rmic
 classname="se.lentus.lentus.serveraccess.Server$$CallProgressProxy"
          base="${lentus.build.classes}">
           <classpath>
            <pathelement location="${util.classpath}" />
           </classpath>
         </rmic>
   </target>
 
 -------------------------
 Output
 rmic:
 java.lang.NoClassDefFoundError: com/sun/corba/se/internal/util/Utility
         at
 sun.rmi.rmic.RMIGenerator.sourceFileForClass(RMIGenerator.java:186)
         at sun.rmi.rmic.RMIGenerator.<init>(RMIGenerator.java:267)
         at sun.rmi.rmic.RMIGenerator.generate(RMIGenerator.java:105)
         at sun.rmi.rmic.Main.doCompile(Main.java:526)
         at sun.rmi.rmic.Main.compile(Main.java:133)
         at org.apache.tools.ant.taskdefs.Rmic.execute(Rmic.java:210)
         at org.apache.tools.ant.Target.execute(Target.java:142)
         at org.apache.tools.ant.Project.runTarget(Project.java:818)
         at org.apache.tools.ant.Project.executeTarget(Project.java:532)
         at
org.apache.tools.ant.Project.executeTargets(Project.java:506)
         at org.apache.tools.ant.Main.runBuild(Main.java:420)
         at org.apache.tools.ant.Main.main(Main.java:149)
 error: An error has occurred in the compiler; please file a bug report
 (http://java.sun.com/cgi-bin/bugreport.cgi).
 1 error
 
 
 Regards,
 Peter

Mime
View raw message