ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <>
Subject Re: Javac, Jikes and java 1.1-1.3
Date Wed, 15 Nov 2000 01:13:29 GMT
At 01:24  14/11/00 -0800, you wrote:
>on 11/14/2000 1:14 PM, "Shamberger, Michael" <>
>> Jon,
>> The jikes compiler (I'm using 1.12) has a -depend option that deals with
>> package dependencies similar to the way javac does.
>> Mike
>Right, but the thing is that I can compile Turbine with javac without having
>to use the -depend option. So, I would "assume" that it would work with
>Jikes as well, right?

Why assume anything ? Javac is a horribly broken non-compliant compiler -
you don't assume - you hope that it does what is supposed to do ;)

>I also don't see a -depend option with this JVM ( I know it is old...but
>people still use old software)...

It has been at various stages -Xdepend and I believe in 1.3 it was rolled
into compiler as default (and thus no switch).



| Despite your efforts to be a romantic hero, you will |
| gradually evolve into a postmodern plot device.      |

View raw message