ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From meta...@locus.apache.org
Subject cvs commit: jakarta-ant/src/antidote/org/apache/tools/ant/gui Main.java
Date Tue, 14 Nov 2000 19:55:45 GMT
metasim     00/11/14 11:55:45

  Modified:    src/antidote/org/apache/tools/ant/gui Main.java
  Log:
  Added warning about incompatibility with vm version "Blackdown-1.3.0-RC1".
  
  Revision  Changes    Path
  1.3       +9 -1      jakarta-ant/src/antidote/org/apache/tools/ant/gui/Main.java
  
  Index: Main.java
  ===================================================================
  RCS file: /home/cvs/jakarta-ant/src/antidote/org/apache/tools/ant/gui/Main.java,v
  retrieving revision 1.2
  retrieving revision 1.3
  diff -u -r1.2 -r1.3
  --- Main.java	2000/11/06 12:52:43	1.2
  +++ Main.java	2000/11/14 19:55:45	1.3
  @@ -59,7 +59,7 @@
   /**
    * Launch point for the Antidote GUI. Configurs it as an application.
    * 
  - * @version $Revision: 1.2 $ 
  + * @version $Revision: 1.3 $ 
    * @author Simeon Fitch 
    */
   public class Main {
  @@ -70,6 +70,14 @@
   	 */
       public static void main(String[] args) {
           XMLHelper.init();
  +
  +        String vmVersion = System.getProperty("java.vm.vendor");
  +        if(vmVersion.indexOf("Blackdown") > 0 &&
  +           vmVersion.indexOf("RC") > 0) {
  +            System.err.println("Warning: Antidote will not work with VM version Blackdown-1.3.0-RC1.");
  +            System.err.println("Your version: " + vmVersion);
  +        }
  +
           try {
               JFrame f = new JFrame("Antidote");
               AppContext context = new AppContext(f);
  
  
  

Mime
View raw message