ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew Dornquast" <matt...@cata.com>
Subject Javac, Jikes and java 1.1-1.3
Date Tue, 14 Nov 2000 16:44:22 GMT
My company is ready to move from java 1.1 into 1.2 or 1.3 (YAY!), but javac
is crappy slow (BOO), and we've grown addicted to jikes (YAY!)

so in the spirit of, "No question is a stupid question"

Q: Can I use Jikes to compile my code for Java 1.1, Java 1.2 and Java 1.3?

I think the answer is yes.  But I'm not "you bet your life" confident, so I
thought I'd ask my peers (supeers?) on the list.

I think the answer is "Go ahead and bet your life Matt".  So long as the
language spec isn't incompatible between version (say java 1.1 and 1.2) and
the VM/class bytecode specification doesn't change, I'm ok.

I mean, byte code is byte code right?  I make sure jikes has access to the
java runtime classes for java 1.3 when compiling and I'm golden.  I tried
this, and for my few simple test cases, it seemed to work.

I imagine an Ant build script where I do "developer builds" with jikes--
which screams, and javac with full optimizations on/debug off for production
build/release.

-Matthew


Mime
View raw message