ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Meade" <eme...@geekfarm.org>
Subject Re: Build Failed
Date Thu, 12 Oct 2000 01:54:55 GMT
Yes, I should have been more specific I bet...  Originally, I
couldn't get Ant to build.  Jose hooked me up by telling me
to bootstrap, that got Ant building ( of course ).  Then when
I ran ant runtests, I got:

    [junit] Testsuite: org.apache.tools.ant.taskdefs.GzipTest
    [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec
    [junit]
    [junit]     Caused an ERROR
    [junit] Prohibited package name: java.lang
    [junit] java.lang.SecurityException: Prohibited package name: java.lang

I just updated from cvs, I still get it.  I've also tried running
without hotspot, by specifing -classic in the ant.bat and using
<jvmarg value="-classic"/> in the junit task.

Erik Meade


> -----Original Message-----
> From: Conor MacNeill
> Sent: Monday, October 09, 2000 2:16 PM
> To: ant-dev@jakarta.apache.org
> Subject: RE: Build Failed
>
>
> I suspect this will be to do with overlapping classpaths between ant (the
> system classloader) and the classloader being used within the JUnit task.
> For me, I had problems only under hotspot, which seems to have a slightly
> different way of managing loaded classes. Under 1.3 without hotspot, it
> would be OK.
>
> I wrote down some info when I was working on the class loader for
> EJBC which
> I can provide, if I can find it.
>
> I have had reports of some people having similar problems with ejbc lately
> although I haven't had time to follow those up in detail yet.
>
> Conor
>
> +1 on classloaders being a pain.
>
> --
> Conor MacNeill
> Cortex eBusiness
> http://www.cortexebusiness.com.au
>
> > -----Original Message-----
> > From: Craig R. McClanahan
> > Sent: Tuesday, 10 October 2000 2:59
> > To: ant-dev@jakarta.apache.org
> > Subject: Re: Build Failed
> >
> >
> > Stefan Bodewig wrote:
> >
> > > >>>>> "EM" == Erik Meade writes:
> > >
> > >  >> From: Stefan Bodewig
> > >
> > >  >>  Which JDK is this?
> > >  EM> C:\>java -version java version "1.3.0" Java(TM) 2 Runtime
> > >  EM> Environment, Standard Edition (build 1.3.0-C) Java HotSpot(TM)
> > >  EM> Client VM (build 1.3.0-C, mixed mode)
> > >
> > > Which probably means I'll need to download Sun's preview 1.3 for
> > > Linux, it doesn't cause any problems with IBM's (should IBM's
> > > ClassLoader implementation be different from Sun's?).
> > >
> >
> > I'm currently investigating a classloader-related problem with Tomcat
> > 4.0 that shows up with 1.3 -- the app works under 1.2.2.  I'll share
> > anything I learn here.
> >
> > >
> > > Just wanted to add that I hate ClassLoaders.
> >
> > +1
> >
> > :-)
> >
> > >
> > > Stefan
> >
> > Craig McClanahan


Mime
View raw message