ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Parker, Daniel" <Daniel.Par...@schwab.com>
Subject Problems with ant on WindowsNT
Date Sun, 08 Oct 2000 01:16:37 GMT
I've installed the binary version of ant on a Windows NT machine.  The
accompanying ant user manual indicates Version 1.0.8 - 2000/03/04.
I downloaded the binary version so there's a bin directory in the path which
has an ant.bat file which is what I use.
I've got the following system variables set:

ANT_HOME=C:\Tools\ant\jakarta-ant
JAVA_HOME=C:\Tools\jdk1.1.8

I have a very simple build file similiar to the example in the documentation

<project name="myproject" default="compile" basedir=".">
  <target name="init">
    <tstamp/> 
    ...other properties...
  </target>

  <target name="prepare" depends="init">
    <mkdir dir="${build}" />
    <mkdir dir="${build.classes}"/>
  </target>

  <target name="compile" depends="prepare">
    <javac srcdir="${src}" destdir="${build.classes}"
classpath="${classpath}" filtering="on"/>
  </target>
</project>

If I run ant, I see the output

Executing Target: compile
Compiling 14 source files to C:\build\classes

Now, there are in fact 14 java files in the srcdir and the target directory
shown is correct, but nothing gets put in the target directory!

Now, if I run ant in verbose mode, I see the output

Setting project property: ant.java.version -> 1.3
Setting project property: sun.boot.class.path -> C:\Program
Files\JavaSoft\JRE\1.3\lib\rt.jar;
C:\Program Files\JavaSoft\JRE\1.3\lib\i18n.jar;
C:\Program Files\JavaSoft\JRE\1.3\libsunrsasign.jar;
C:\Program Files\JavaSoft\JRE\1.3\classes

But I specified jdk1.1.8!!!  The indicated 1.3 files are on my local drive,
but they're not anywhere in my environment variables.

If I set the build.compiler property to "classic", I get an error message 

javac: invalid flag: -sourcepath

What's going on???

Thanks,
Daniel Parker

Mime
View raw message