ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@m64.com>
Subject RE: interesting ant.bat problem...you need to have a classpath sp ecif ied
Date Mon, 30 Oct 2000 13:40:20 GMT
Can you remove the echo off statement at the top of ant.bat and send us
the output when it fails. It works for me on NT with no classpath.

Conor


> -----Original Message-----
> From: Mikkel Bruun [mailto:mikkel.bruun@valtech.dk]
> Sent: Friday, 27 October 2000 16:33
> To: 'KC Baltz '; ''ant-dev@jakarta.apache.org' '
> Subject: RE: interesting ant.bat problem...you need to have a
> classpath
> sp ecif ied
>
>
>  java.exe returns with the argument list. Signalling that it
> has been called
> with incorrect/incomplete parameters...
>
> Mikkel
>
> -----Original Message-----
> From: KC Baltz
> To: 'ant-dev@jakarta.apache.org'
> Sent: 26-10-2000 17:28
> Subject: RE: interesting ant.bat problem...you need to have a
> classpath sp
> ecif ied
>
> What kind of failure are you getting?  Because in NT, I don't have a
> CLASSPATH variable defined and Ant works fine.  I know there are
> differences
> in how .bat files behave on win2K, so that may be it.
>
> K.C.
>
> > -----Original Message-----
> > From: Mikkel Bruun [mailto:mikkel.bruun@valtech.dk]
> > Sent: Thursday, October 26, 2000 11:24 AM
> > To: 'ant-dev@jakarta.apache.org'
> > Subject: interesting ant.bat problem...you need to have a classpath
> > specif ied
> >
> >
> > Hi guys!
> >
> > Ran into a small problem (ant 1.2, win2k, jdk1.3)
> > Apparently you have to have CLASSPATH defined in your
> > enviroment settings or
> > else the following line from the ant.bat will fail:
> >
> > ---------->
> > %JAVACMD% -classpath %LOCALCLASSPATH% -Dant.home="%ANT_HOME%"
> > %ANT_OPTS%
> > org.apache.tools.ant.Main %ANT_CMD_LINE_ARGS%
> > <-----------
> > As the local path is "" which java.exe apparently cant handle...
> >
> > Now I know that most people (99.9%) already has a CLASSPATH
> > setting so it
> > isnt really a problem...
> >
> > Workaround? just add a CLASSPATH having it point to some
> directory...
> >
> > regards
> > Mikkel Bruun
> > mikkel.bruun@valtech.dk
> >
>


Mime
View raw message