ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [PATCH] The build.bat and ant.bat files don't actually work for the install target and using jikes in Win98
Date Tue, 05 Sep 2000 14:27:26 GMT
Hey all.  I was trying to set up my home environment (Win98 - don't laugh, 
I have a wife and an extended family that would die is they had to use 
linux... :-[ ) to do some ant development, and I ran into a couple of 
snags.  I was trying to compile the CVS version and simply install it to 
d:\ant.  Didn't work.  I took a peek at build.bat, and it seems that the 
line to add -Dant.install=BLAH didn't have the =.  Add it in, and you get 
a Syntax error.  Lovely. 

I spent about two hours scouring the net to see how to embed an equals 
sign in a dos set statement ('cause there are NO decent docs that come 
with Win98), and I couldn't find it.  So, this patch does the same test as 
before, except that it explictly calls and with -Dant.install=BLAH, rather 
than trying to do it with  variable substitution.

Looking at the other files, ant.bat had the same problem with the 
autodection of the Jikes directory.  I don't have jikes, but I set the 
environment variable just for kicks, and I got the same syntax error. Same 

Glenn McAllister
Software Developer. IBM Toronto Lab, (416) 448-3805
"An approximate answer to the right question is better than the 
right answer to the wrong question." - John W. Tukey
View raw message