ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@cortexebusiness.com.au>
Subject RE: Problem with javac task and JDK 1.1
Date Wed, 12 Jul 2000 03:55:37 GMT
Russell,

Can you run ant at verbose level to see what ant thinks the JDK version is.
The only use of -sourcepath in Javac.java is inside modent compile and the
following

if (Project.getJavaVersion().startsWith("1.1")) {
     argList.addElement(classpath + File.pathSeparator +
                        getSourcePath());
} else {
     argList.addElement(classpath);
     argList.addElement("-sourcepath");
     argList.addElement(getSourcePath());
     if (target != null) {
         argList.addElement("-target");
         argList.addElement(target);
     }
}

Conor

--
Conor MacNeill
conor@cortexebusiness.com.au
Cortex eBusiness
http://www.cortexebusiness.com.au

> -----Original Message-----
> From: Russell Gold [mailto:russgold@acm.org]
> Sent: Wednesday, 12 July 2000 13:10
> To: ant-dev@jakarta.apache.org
> Subject: Problem with javac task and JDK 1.1
>
>
> For various reasons, I have had to revert to JDK 1.1. I did this
> by changing my JAVA_HOME symbol and my path and classpath - but
> now I get errors in the javac task, which insists on passing
> "-sourcepath" to the compiler, which doesn't recognize the option
> and chokes. Is there an alternate switch to tell ant to use
> options appropriate for JDK 1.1 and not JDK 1.2?
>
> ------------------------------------------------------------------------
> Russell Gold                     | "... society is tradition and order
> russgold@acm.org    (preferred)  | and reverence, not a series of cheap
> russgold@netaxs.com              | bargains between selfish interests."
> rgold@thesycamoregroup.com       |   - Poul Anderson, "Iron"
>
>
>


Mime
View raw message