ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@cortexebusiness.com.au>
Subject RE: Classpath issues
Date Tue, 25 Jul 2000 01:59:16 GMT
I made a little change regarding this but I haven't committed it yet. I
simply added a setPath method to the Environment.Variable class so that you
could pass a patform specific path (classpath) from a platform-independent
build file.

--
Conor MacNeill
conor@cortexebusiness.com.au
Cortex eBusiness
http://www.cortexebusiness.com.au

> -----Original Message-----
> From: David Forslund [mailto:dwf@lanl.gov]
> Sent: Tuesday, 25 July 2000 6:57
> To: ant-dev@jakarta.apache.org
> Subject: Classpath issues
>
>
> I want to use a classpath from ant and send it on as a argument of a
> separate program that is being executed.
> It could be set as an environment variable for that task (under
> exec), but
> I don't see how to set an environment variable for an exec task.  The
> problem is that I can build up a classpath, but it will have "\"
> and "/" in
> it.  When the
> task is executed by ant, all the "\" are removed (I guess they are simply
> taken as passing the next literal through).  As a result the classpath
> argument is completely incorrect and my application fails.   How
> can I get
> Ant to pass
> through the classpath literally (or better, make sure that it has proper
> classpath syntax).  The <classpath /> item doesn't work in this case
> because it isn't an explicit argument of the exec task.
>
> Any suggestions as to how to do this correctly, would be greatly
> appreciated.
>
> David W. Forslund                               dwf@lanl.gov
> Advanced Computing Laboratory           http://www.acl.lanl.gov/~dwf
> Los Alamos National Laboratory          Los Alamos, NM 87545
> 505-665-1907                                    FAX: 505-665-4939
>
>


Mime
View raw message